DEFCON Desktop Linux app (UNOFFICIAL)

iron_eagl

Member
As you may have noticed with the system test today, my mistaken understanding of how shell conditionals were written meant that a notification window popup would *never* be shown, not just not upon connecting/disconnecting. That has now been fixed, and the updated code is on GitHub. I don't know how I missed testing for that.
 

DEFCON Warning System

Director
Staff member
Have you tried making your own code file, like test.dat, and having your app poll that? That way you can test it to your heart's content.

As of now, there are no further System tests planned.
 

RiffRaff

Deputy Director
Staff member
DEFCONWarningSystem said:
Have you tried making your own code file, like test.dat, and having your app poll that? That way you can test it to your heart's content.

As of now, there are no further System tests planned.

That would be extremely helpful...
 

RiffRaff

Deputy Director
Staff member
Seems to be working for me, but as long as we remain at DEFCON 5, hard to tell how it will react to real-world alert bumps, or how it would react past DEFCON 4, which is as high as it's gone while I've had it installed.
 

RiffRaff

Deputy Director
Staff member
DEFCONWarningSystem said:
Has it been tested with a test file? Just change the file from code.dat to www.yourserver.com/test.dat and put it through its paces.

Okay, I'll try to get to that next week.
 

RiffRaff

Deputy Director
Staff member
Okay, minor snowball in the works somewhere with this. I've placed the DWS-linux.sh in my personal Startup Applications, and while the program does start, it won't update the level. I just get the grey "NC" icon. However, if I quit the application and go double-click that script manually, it starts up perfectly. I've done a lot of troubleshooting - path, permissions, etc. - to try and figure out why it will work by manually starting it but not when it's configured to startup automatically. Any thoughts on this?
 

iron_eagl

Member
I think it’s related to there not being a desktop at the point when it gets called on startup - have you tried putting a delay in the startup command to bash?

I still run into just a YAD icon appearing on first login sometimes, but right-click “refresh”-ing works for me. I don’t think I’ve ever had it stuck at the “NC” icon on startup, though.

Have you tried putting the command in the ~/.profile file? That might give different results compared to Startup Applications.

During the next week I’m in the throes of university final exams, but I’ll see if I can figure anything out from my end.

You might also want to try the “twitter” branch, that’s my current dev branch and I might have fixed something without properly committing it back to the main branch. The twitter stuff works off of another script, and can be completely disabled in the main config file. Parsing doesn’t work all the time, and I haven’t found a sustainable way to get a twitter rss feed, that’s why I haven’t merged it yet.
Thanks for trying it out!
 

RiffRaff

Deputy Director
Staff member
iron_eagl said:
I think it’s related to there not being a desktop at the point when it gets called on startup - have you tried putting a delay in the startup command to bash?

I still run into just a YAD icon appearing on first login sometimes, but right-click “refresh”-ing works for me. I don’t think I’ve ever had it stuck at the “NC” icon on startup, though.

Have you tried putting the command in the ~/.profile file? That might give different results compared to Startup Applications.

During the next week I’m in the throes of university final exams, but I’ll see if I can figure anything out from my end.

You might also want to try the “twitter” branch, that’s my current dev branch and I might have fixed something without properly committing it back to the main branch. The twitter stuff works off of another script, and can be completely disabled in the main config file. Parsing doesn’t work all the time, and I haven’t found a sustainable way to get a twitter rss feed, that’s why I haven’t merged it yet.
Thanks for trying it out!

Thanks for your response. I will try out your suggestions and let you know what I get. Good luck on finals.
 

RiffRaff

Deputy Director
Staff member
Okay, it's not a delay problem. I created a launcher on the panel to make it easier to launch, but I get the same NC icon problem. Any attempt to launch the program by any method other than double-clicking the actual executable gives me a permanent NC icon.
 

iron_eagl

Member
Interesting....

I've switched my installation back over to the master branch, and no issues... What linux Distribution are you using and what version? Sometime over the next few days I should be able to set up a VM and see if I can replicate your issue. By "any other method"... does this include launching it from a terminal window by "./DWS-linux.sh"? If it fails, it should give some indication as to why. If not... I have no idea why it would work in a terminal but not when Startup Applications calls it.

Does right-clicking on the icon and hitting refresh get it to work, or does it stay on "NC"?

What does "ls -l" look like for the DWS-linux folder?
 

RiffRaff

Deputy Director
Staff member
I'm using Linux Mint 18.1 with the Mate Desktop. Sorry, I should have stated that launching it from command line works as well, I just considered that the same as running it directly from the GUI. It's only if I try to create any kind of shortcut to it, including in startup applications, that it launches but just remains at the NC icon. Even if I right-click and hit refresh. ls -l seems to be fine; all files and directories list me as the owner and the application is listed as an executable. I can post a screen capture if that would help.
 

iron_eagl

Member
So... I installed a vm, and, long story short, it appears that pgrep was not finding yad when it first entered the loop (maybe 0.27.0 just takes a while - what version of yad are you running? (yad --version)). No idea why this would be an issue with Mint and not Ubuntu. Anyways, I added in a delay before the main loopy bit - it should still display the NC icon for the first 10-ish seconds, but then it should update. I also changed the wget command to write the output to log.txt, to help see if there's a wget issue. Try pulling the repository.

If this isn't it.... Try re-installing everything? (Delete and re-clone the repository, purge and reinstall wget and yad). Maybe it's a wgetrc issue? Do you have a proxy or VPN? Maybe triple-check all the filepaths you are using for Startup Applications, etc.?
 

RiffRaff

Deputy Director
Staff member
Using yad 0.27.0. However, interestingly enough, I got the following warning when running that command:

(yad:16262): Gtk-WARNING **: Theme directory of the oxygen has no size field

Is it possible for an issue with my desktop theme to interfere with the running of this program somehow? I'll reinstall the program with your changes and see if it acts differently and let you know.
 

RiffRaff

Deputy Director
Staff member
@RiffRaff - Any updates?

Okay. got the new release downloaded and installed today. I haven't had a chance to try a full reboot, but I can tell you that the shortcut I placed on my tool bar now launches the program properly, whereas it would not before. So I am hopeful the autostartup on boot will work as well. I'll report on that as soon as I get a chance to reboot.
 
Top